[Notes] Network Planning and Administration: Dynamic Routing Protocols

Miguel Menéndez

Dynamic routing protocols.

To view the dynamic routing protocols on the router:

Router# show ip protocols

And to see the route table on the router:

Router# show ip route

RIPv2

RIP is a dynamic routing protocol based on distance vector, hop count, more hops, more metric. To configure it on the router:

Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network 192.168.10.0
Router(config-router)# network 172.20.0.0

(network are the networks to which the router is tapped with each adapter)

So that it does not spread information through a specific mouth because there are no more routers in it:

Router(config-router)# passive-interface Fa0/1

If the router has a default route established (for example, to the internet: ip route 0.0.0.0 0.0.0.0 195.34.12.8):

Router(config-router)# default-information originate

##EIGRP

EIGRP is a dynamic routing protocol that, in addition to counting hops, also takes into account other factors such as bandwidth to calculate the metric. To configure it on the router:

Router(config)# router eigrp 1
Router(config-router)# network 172.20.0.8 0.0.0.3
Router(config-router)# network 172.20.0.12 0.0.0.3

(1 is the autonomous system number -invented, but the same for all routers-, network are the networks to which the router is tapped: 172.20.0.8/30 and 172.20 .0.12/30)

So that it does not spread information through a specific mouth because there are no more routers in it:

Router(config-router)# passive-interface Fa0/1

If the router has a default route established (for example, to the internet: ip route 0.0.0.0 0.0.0.0 195.34.12.8):

Router(config-router)# redistribute static

OSPF

OSPF is a dynamic routing protocol that takes into account various factors such as bandwidth to calculate the metric but does not consider the number of hops. OSPF designates one of the network routers (DR, Designated Router) to collect the information and broadcast it (it is the one with the ID 1: Router(config-router)# router-id 1.1.1.1). To configure it on the router:

Router(config)# router ospf 1
Router(config-router)# network 172.20.0.8 0.0.0.3 area 1
Router(config-router)# network 172.20.0.12 0.0.0.3 area 1

(1 is the process number -invented, but different for each router-, network are the networks to which the router is tapped: 172.20.0.8/30 and 172.20.0.12/ 30, area 1 must have the same value -whatever- on all routers)

So that it does not spread information through a specific mouth because there are no more routers in it:

Router(config-router)# passive-interface Fa0/1

If the router has a default route established (for example, to the internet: ip route 0.0.0.0 0.0.0.0 195.34.12.8):

Router(config-router)# default-information originate

Comments

Found a bug? Do you think something could be improved? Feel free to let me know and I will be happy to take a look.